Facebook рекомендует пользователям WhatsApp обновить приложение

Facebook настоятельно рекомендует всем пользователям WhatsApp срочно обновить приложение под Android, так как стало известно о критической уязвимости, чреватой удаленным запуском произвольного кода на мобильном устройстве.

Дыра, которую обнаружил независимый эксперт по информационной безопасности под псевдонимом Awakened, относится к классу double-free или «двойное освобождение памяти». Это ошибка, при которой программа дважды обращается с вызовом free() (команда на освобождение) к одной и той же области памяти, что приводит к нарушению ее целостности. Вследствие этого приложение либо «падает», либо при определенных условиях у потенциального злоумышленника появляется возможность записывать посторонние данные в память. В конечном счете это может приводить к захвату контроля над устройством.

Awakened уведомил Facebook о своем открытии еще в сентябре 2019 г., и WhatsApp был поспешно обновлен до версии 2.19.244.

 

Читайте новости первыми в нашем Telegram-канале!

Подписывайтесь на наш канал в Яндекс.Дзен!

Версия для печатиВерсия для печати

Регион: 

Рубрики: 

Заметили ошибку? Выделите ее мышкой и нажмите Ctrl+Enter!